Network Configuration issues

General support questions and discussions.

Network Configuration issues

Postby lizgallegos » Fri Feb 26, 2016 11:32 pm

When I open a web browser and type in the IP address I configured my Arduino to listen to (192.168.0.115), from step #4 of the software configuration process I get the following error:

This webpage is not available

ERR_CONNECTION_TIMED_OUT

I've tried using different browsers, different computers and my cell phone, I don't get a response on any of them. Below is the code I uploaded to the Arduino. Arduino IDE said the upload was successful.


// EthernetShield IP address (DHCP reserved, never allocated to anyone else). This is the internal
// network IP address you want your Arduino assigned. This is not the address you will be accessing
// your Arduino from the iPhone application or internet ... You need to configure NAT forwarding
// on your home router to do that. See http://en.wikipedia.org/wiki/Port_forwarding for more details.

uint8_t ip[4] = { 192, 168, 0, 115 };

// Port on which Arduino HTTP server will listen to

int port = 8081;

// MAC address to be used by ethernet adapter

uint8_t mac[6] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };

// password required for operating door [max length = 16] (status fetching doesn't require password). This
// must match the password you set in the iPhone application (be careful as case is sensitive).

char* password = "xxxxx";

// Do not remove the following server definitions

EthernetServer server(port);
MyDoorOpenerServer myDoorOpenerServer(password, mac, ip);

I changed the port to 8081 as my ISP blocks port 80. Below are the IP address reservation and port forwarding I did on my router (TpLink Model No. TL-WR841N / TL-WR841ND):


ID MAC Address Reserved IP Address Status
2 DE-AD-BE-EF-FE-ED 192.168.0.115 Enabled

ID Service Port Internal Port IP Address Protocol Status
2 8081 8081 192.168.0.115 All Enabled
lizgallegos
 
Posts: 4
Joined: Fri Feb 26, 2016 10:19 pm

Re: Network Configuration issues

Postby support » Sun Feb 28, 2016 9:56 am

That IP address is your internal network IP address. Few things to check:

1) Are you on WiFi when you carry out that test?

2) Is that IP address you configured your Arduino with on the same subnet as your home router? For example, if your home router address is 192.168.0.1, you should setup your Arduino to something like 192.168.0.115

3) Is you Arduino powered on and properly connected to the network?

4) Are you sure you uploaded your updated MyDoorOpener sketch to your Arduino?

5) I also noticed you've configured using port 8081. Have you included that in the URL you're using when connecting? such as http://192.168.0.115:8081 ... If you use port 80, you won't need to specify this as 80 is the default.

Best regards,
support
Site Admin
 
Posts: 384
Joined: Thu Aug 22, 2013 7:30 pm

Re: Network Configuration issues

Postby lizgallegos » Mon Feb 29, 2016 10:14 pm

Apparently the second half of my post got cut off, here it is:

When I ping it I get the following, it appears to be responding:

C:\Users\Lemon>ping 192.168.0.115

Pinging 192.168.0.115 with 32 bytes of data:
Reply from 192.168.0.115: bytes=32 time=86ms TTL=128
Reply from 192.168.0.115: bytes=32 time=35ms TTL=128
Reply from 192.168.0.115: bytes=32 time=89ms TTL=128
Reply from 192.168.0.115: bytes=32 time=39ms TTL=128

Ping statistics for 192.168.0.115:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 35ms, Maximum = 89ms, Average = 62ms

As far as the hardware setup goes I'm using COM2/NO2 for the relay to control the opening of the garage door and Analog pin #4 for my status sensing device. I've got it wired up as shown in the tutorial document. The reason I'm not using COM1 and analog pin 3 is because I had some soldering issues while trying to solder to A3 and was forced to use A4 instead. The Arduino is receiving power and an ethernet cable is attached (I verified that the ethernet connection is good, I had no trouble getting on the internet when I plugged it in to my computer).

In answer to your questions:

1) I am not on wifi when I carry out the test I'm on a computer connected to the network with an ethernet cable.

2) My home router address is 192.168.0.1 so the Arduino's IP address of 192.168.0.115 should be on the same subnet as the router as far as I know.

3) The Arduino is powered on and connected to the network with an ethernet cable.

4) I got an upload successful message in IDE when I uploaded the sketch, and I uploaded the updated version, I double checked.

5) When I use http://192.168.0.115:8081 I get the following response:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<myDoorOpener>
<status statusPin="3">Closed</status>
<status statusPin="4">Closed</status>
<challengeToken>Cyber618230</challengeToken>
</myDoorOpener>

I can't use port 80, my router will not allow it. I get the following error message when I try to use port 80 for port forwarding:

Error: The port of the remote web management is conflicting with of the virtual server.
lizgallegos
 
Posts: 4
Joined: Fri Feb 26, 2016 10:19 pm

Re: Network Configuration issues

Postby support » Mon Mar 07, 2016 10:08 pm

Assuming you're running this on your local network (over WiFi on your phone), what happens if you configure the iOS app to use the http://192.168.0.115:8081 URL ? Does that work ?

If so, all you need to figure out is how to perform NAT port forwarding for your router can forward 192.168.0.1:PORT -> 192.168.0.115:8081 ...
support
Site Admin
 
Posts: 384
Joined: Thu Aug 22, 2013 7:30 pm

Re: Network Configuration issues

Postby lizgallegos » Tue Mar 08, 2016 3:36 am

When I use http://192.168.0.115:8081 as the URL in the iOS app it will show me the status of the device, however it will not open or close the garage door when I push the "open" or "close" buttons on the screen. I'm guessing that is a completely different issue as if I didn't already have enough.

I have watched every video and read every article I could find on NAT port forwarding for my router (TpLink Model No. TL-WR841N) and they all say pretty much the same thing, to go to the Forwarding tab and click on Virtual Server and then put in the IP address and the Service port which I have done. I don't know what else to try. I've attached screen captures of the forwarding I did on my router. I set the IP address to 192.168.0.115 which is the IP address I reserved for the Arduino and I set the Service Port to 8081 as the router will not allow me to use port 80. I changed the port in the Arduino code to 8081 to match this. The Internal Port automatically got set to 8081 as well when I left that field blank. I left Common Service Port black as well as none of the articles I found on port forwarding for my router mentioned doing anything with that selection box. It has options like DNS, FTP, GOPHER, HTTP, etc. The other port forwarding rule I have set up that you see in the capture works fine, it's for my Plex media server.

I don't know what else to try but this whole project is a bust if I can't get this to work, the whole point of installing this was to be able to monitor my garage door status remotely.

Capture.PNG
Port forwarding overall
Capture.PNG (178.24 KiB) Viewed 5209 times

Capture2.PNG
Port forwarding specific
Capture2.PNG (17.47 KiB) Viewed 5209 times
lizgallegos
 
Posts: 4
Joined: Fri Feb 26, 2016 10:19 pm

Re: Network Configuration issues

Postby support » Tue Mar 08, 2016 8:39 pm

May I suggest that you first get this to work from within your internal network and then move on to having it work from the internet.

For port forwarding, it looks like you configured your external port to be 8081. So basically what this means is that you should
be able to access your Arduino using the iOS app (or browser) thru your ISP provided IP address ...

Basically, go to https://www.whatismyip.com/ and determine what your public/external IP currently is and add :8081 at the end. It should
work unless your ISP is blocking port 8081 which is a possibility.

From outside your home network, you should not be using 192.168.0.1:8081 nor 192.168.0.115:8081 but instead
use <your public/external ip>:8081. This should also work from internally but will go on the internet and back to your internal network.

This will hit your home router and port forwarding of port 8081 at your external IP will get forwarded to 192.168.0.115:8081
as per your current NAT port forwarding rules.

Again, before doing this I suggest you first get the relay working from within your internal network.

Good luck!
support
Site Admin
 
Posts: 384
Joined: Thu Aug 22, 2013 7:30 pm

Re: Network Configuration issues

Postby lizgallegos » Tue Mar 08, 2016 11:34 pm

Thanks that worked!
lizgallegos
 
Posts: 4
Joined: Fri Feb 26, 2016 10:19 pm

Re: Network Configuration issues

Postby support » Thu Mar 10, 2016 9:14 pm

Great! All ends well ... :-)
support
Site Admin
 
Posts: 384
Joined: Thu Aug 22, 2013 7:30 pm


Return to Support



cron